Imported Upstream version 1.2.0
[psensor-pkg-debian.git] / tests / Makefile.am
index 554305d..5bf8b1f 100644 (file)
@@ -5,6 +5,7 @@ check-local: checkpatch.pl
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 
 EXTRA_DIST = checkpatch.pl \
+       spelling.txt \
        test-cppcheck.sh \
        test-io-dir-list.sh
 
@@ -29,7 +30,9 @@ endif
 
 test_io_dir_list_SOURCES = test_io_dir_list.c
 test_psensor_type_to_unit_str_SOURCES = test_psensor_type_to_unit_str.c
+test_psensor_type_to_unit_str_CFLAGS = -I$(top_srcdir)/src/lib
 test_psensor_value_to_str_SOURCES = test_psensor_value_to_str.c
+test_psensor_value_to_str_CFLAGS = -I$(top_srcdir)/src/lib
 test_url_encode_SOURCES = test_url_encode.c
 test_url_normalize_SOURCES = test_url_normalize.c
 
@@ -41,4 +44,4 @@ TESTS = test-io-dir-list.sh \
 
 if CPPCHECK
 TESTS += test-cppcheck.sh
-endif
\ No newline at end of file
+endif