Imported Upstream version 1.1.2
[psensor-pkg-debian.git] / src / Makefile.am
index 0f64275..3ddb1e7 100644 (file)
@@ -9,14 +9,13 @@ SUBDIRS += server
 endif
 endif
 
-# -no-deprecated-declarations to avoid some glib deprecation warnings
-AM_CPPFLAGS = -Wno-deprecated-declarations -Wall -Werror \
+AM_CPPFLAGS =-Wall -Werror \
        -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
        -DDATADIR=\""$(datadir)"\"\
+       -DPSENSOR_DESKTOP_FILE=\""psensor.desktop"\"\
        -I$(top_srcdir)/src/lib \
        -I$(top_srcdir)/src/unity \
        $(GTK_CFLAGS)\
-       $(GCONF_CFLAGS)\
        $(SENSORS_CFLAGS)
 
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
@@ -24,20 +23,17 @@ DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 LIBS = \
        lib/libpsensor.a \
        $(GTK_LIBS)\
-       $(GCONF_LIBS)\
        $(PTHREAD_LIBS)\
-       $(SENSORS_LIBS)
+       $(SENSORS_LIBS) -lm
 
 if GTK
 if X11
 if XEXT
-if GCONF
 bin_PROGRAMS = psensor
 dist_man_MANS = psensor.1
 endif
 endif
 endif
-endif
 
 psensor_SOURCES = \
        cfg.h cfg.c \
@@ -88,6 +84,10 @@ AM_CPPFLAGS += $(ATASMART_CFLAGS)
 LIBS += $(ATASMART_LIBS)
 endif
 
+if LIBUDISKS2
+LIBS += $(LIBUDISKS2_LIBS)
+endif
+
 if UNITY
 psensor_SOURCES += ui_unity.h ui_unity.c
 AM_CPPFLAGS += $(UNITY_CFLAGS)
@@ -102,17 +102,11 @@ AM_CPPFLAGS += $(CURL_CFLAGS) $(JSON_CFLAGS)
 endif
 endif
 
-EXTRA_DIST = description.txt psensor.schemas
-
-if GCONF
-schemadir = $(GCONF_SCHEMA_FILE_DIR)
-schema_DATA = psensor.schemas
-
-install-data-local:
-       GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_srcdir)/src/$(schema_DATA)
-endif
-
 psensor.1: main.c $(top_srcdir)/configure.ac
        $(MAKE) $(AM_MAKEFLAGS) psensor$(EXEEXT)
        help2man --include=description.txt -N --name="Temperature monitoring application" --output=psensor.1 ./psensor$(EXEEXT)
 
+gsettings_SCHEMAS=psensor.gschema.xml
+EXTRA_DIST = description.txt $(gsettings_SCHEMAS)
+
+@GSETTINGS_RULES@