Imported Upstream version 1.2.0
[psensor-pkg-debian.git] / configure.ac
index 803214d..add0c4e 100644 (file)
@@ -2,7 +2,7 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ([2.69])
-AC_INIT([psensor], [1.1.5],[jeanfi@gmail.com],[psensor],[http://wpitchoune.net/psensor])
+AC_INIT([psensor], [1.2.0],[jeanfi@gmail.com],[psensor],[http://wpitchoune.net/psensor])
 
 AM_INIT_AUTOMAKE([-Wall gnu])
 
@@ -40,9 +40,11 @@ PTHREAD_LIBS=-pthread
 AC_SUBST(PTHREAD_LIBS)
 
 # Checks sensors, required by psensor and psensor-server
-AC_CHECK_LIB(sensors, sensors_init)
+AC_CHECK_LIB(sensors, sensors_init,
+             [SENSORS_LIBS=-lsensors
+             AC_DEFINE([HAVE_LIBSENSORS],[1],[Use libsensors])])
 AC_CHECK_HEADERS([sensors/sensors.h sensors/error.h])
-SENSORS_LIBS=-lsensors
+AM_CONDITIONAL(SENSORS, test -n "$SENSORS_LIBS")
 AC_SUBST(SENSORS_LIBS)
 
 ############### psensor 
@@ -105,26 +107,9 @@ AC_SUBST(LIBNOTIFY_LIBS)
 
 # Checks AppIndicator 
 APPINDICATOR_LIBS=
-
 PKG_CHECK_MODULES(APPINDICATOR, appindicator3-0.1,
      [AC_DEFINE([HAVE_APPINDICATOR],[1],[Use AppIndicator3-0.1])],
      [AC_MSG_WARN(AppIndicator 3-0.1 not present")])
-
-if test "$APPINDICATOR_LIBS" == ""; then
-   PKG_CHECK_MODULES(APPINDICATOR, 
-     appindicator-0.1 <= 0.2.9 , 
-     [AC_DEFINE([HAVE_APPINDICATOR],[1],[Use AppIndicator 0.2.9])
-      AC_DEFINE([HAVE_APPINDICATOR_029],[1],[Use AppIndicator 0.2.9])
-     ],
-     [AC_MSG_WARN(AppIndicator 0.2.9 not present")])
-fi
-
-if test "$APPINDICATOR_LIBS" == ""; then
-   PKG_CHECK_MODULES(APPINDICATOR, 
-     appindicator-0.1 > 0.2.9, 
-     [AC_DEFINE([HAVE_APPINDICATOR],[1],[Use AppIndicator > 0.2.9])], 
-     [AC_MSG_WARN("AppIndicator > 0.2.9 not present")])
-fi
 AM_CONDITIONAL(APPINDICATOR, test -n "$APPINDICATOR_LIBS")
 AC_SUBST(APPINDICATOR_CFLAGS)
 AC_SUBST(APPINDICATOR_LIBS)
@@ -271,6 +256,7 @@ AC_CONFIG_FILES([
 ])
 
 AC_CHECK_PROGS([HELP2MAN], [help2man])
+AM_CONDITIONAL(HELP2MAN, test -n "$HELP2MAN")
 
 AC_CHECK_PROG([ASCIIDOC], [asciidoc], yes)
 AM_CONDITIONAL(ASCIIDOC, test -n "$ASCIIDOC")